CADET Match Index Error, data not useabel?


I am currently working on the the identification of adsorption parameters for PFAS in water.
For this purpose I am using literature data of removal efficiencies for these compounds. The data is not as “clean” as the other examples that I have seen on this forum. The breakthrough curves are not really S shaped and depending on the compound only go to values of c/c0 = 0,5.
Using CADET Match I try to get at least a rough estimation of the adsorption parameters. With the data and model below I get the following error:
(maxValue - minValue) * seq[0] + minValue,
IndexError: list index out of range

Is this a problem with the matching data that I am using or a problem in the settings of my model?

MatchBelkoutebjp.ipynb (106.1 KB)
ultis2.ipynb (12.4 KB)
CADETMATCHtestmodel.h5 (1.7 MB)
GAC1 PFOS.csv (897 Bytes)

Did you upload the right data set? I just looked at the CSV data and it looks like your signal has 31885987.2 seconds or 1.01 years? The signal also looks very strange. The tolerances of the solver will certainly have to be adjusted if your signal really is in the 1e-15 range.


The data is based on a study of a large scale activated carbon adsorber that looked at the breakthrough curve over the time frame of 1 year, but it only shows partial breakthrough for this compound.
As mentioned before the data is not perfect and has more outliers than other things I have seen on this forum.
The question is if this poses a general problem.

With the tolerance of the solver you mean the tolerances of the time integrator?

@w.heymann, what about non-dimensionalization?

Yeah the tolerance on the time integrator. I have looked at this a bit more and so far I have not found any settings for the binding model that create any change in the model at all. You should carefully check the inlet concentration (mol/m^3) and the column length (m), cross section area (m^2) and the flow rate (m^3/s). CADET-Match should be able to calibrate this model but at least in the parameter ranges being used it doesn’t seem there is any impact.

I will have to come back to this in about a week. I am leaving tomorrow on a business trip.

I adjusted a few parameters and changed the time integrator. Playing around with different integrator tolerances still results in the Index Error and no match.

ultis2.ipynb (15.2 KB)

MatchBelkoutebjp.ipynb (106.8 KB)

The Index Error issue can be fixed by just upgrading CADETMatch.

pip install -U cadetmatch

I will look at the parameters now and see if I can figure out what the range should be.