Installation on Ubuntu, conflicting requirements

I an having problems to get the CADET-Tutorials running on a Ubuntu (18.04.6 LTS (Bionic Beaver)). My guess is that the requirements.txt might be missing in the repo?

This is what I have done:

  • git clone GitHub - modsim/CADET-Tutorial: CADET python based interactive tutorials and documentation

  • cd CADET-Tutorial

  • conda create --quiet --yes --prefix ./cadetvenv

  • conda activate ./cadetvenv

  • conda install -c conda-forge cadet
    There I get a really long list of “UnsatisfiableError: The following specifications were found to be incompatible”. I already updated conda and the list shortened, then I installed all the listed packages manually, but still getting now

    • cadet → hdf5[version=‘>=1.10.6,<|>=1.12.1,<|>=1.12.2,<’]
    • cadet → libblas[version=‘>=3.8.0,<4.0a0|>=3.9.0,<4.0a0’]
    • cadet → libgcc-ng[version=‘>=12|>=9.4.0’]
    • cadet → suitesparse[version=‘>=5.10.1,<6.0a0’]
    • cadet → superlu
    • cadet → tbb-devel

I had installed those packages with conda as well.
Since the CADET-Tutorials pae on github says to execute

conda install -c conda-forge --file requirements.txt

however, no requirements.txt file is available (or am I blind?), I was hoping that might be an explanation and thus solution…?

Thanks a lot for any help!

Hi, you’re right, the installation instructions were kinda incomplete. :see_no_evil: I just added them and and hope it works now. Please try again with the following:

git clone
cd CADET-Tutorial
mamba env create -f ./environment.yml
mamba activate cadet

However, I’m not sure if this solves the conflicts you experienced. Ubuntu 18.04 is already a bit behind so maybe this is the issue. Maybe running this on Python 3.10 helps (which is now also automatically installed with the new conda environment). Let me know if you have further issues.



Btw, I can highly recommend using mamba instead of conda. It’s just so much faster…

You can install it (in your base environment) with:

conda install mamba

Afterwards, simply replace all conda commands with mamba

Dear Johannes,

Thanks a lot for your reply and for adding the environment.yml to the Repo.
With that I could finally install cadet and start JupyterLab.

Just wanted to quickly share my experience and issues in case it might help others in the future:

(1) With the installation on Ubuntu 18.04 (this is what runs in our JupyterHub instance), I could’t resolve the issues. They seem to have been related to a missing glibc and after trying a couple of things, I gave up and started a different approach.

(2) Used Anaconda prompt on my Windows Laptop.

  • First updated conda and anaconda, then installed mamba: Here I had to specify conda install mamba -n base -c conda-forge, with simply conda install mamba it didn’t find the package.
  • Trying to install the packages in environment.yml as it was with python=3.10 didn’t work, it gave me errors that I could finally relate to the pip version (22.3.1). (Btw. I also always got the warning, that pip version is not specified in the yml, is that intended?)
  • Setting python=3.8 in the environment.yml finally did the job.
1 Like