umfpack.dll was not found

Hi all,

after some time I am back to CADET but new to the python-version.
I istalled the python-cadet packages and tried to build the example from the CADET Introduction — CADET.
Unfortunately, I get the following system error:

I reistalled anaconda, cadet, and cadet-python. Moreover, I tried to install umfpack.ddl via pip install scikit-umfpack.
With that I have a building wheel error:

Is there someone with a similar problem? I would appreciate any hint to get CADET started again :).
Best regards,

Have you checked whether or not umfpack.dll is inside the ../conda_dir/envs/cadet/Library/bin/? (assuming you installed cadet in the cadet environment.)

If I’m right the above directory should be the place where it’s located at. If you can’t find it, I would first try to remove the environment (and delete any remaining folder or files from that environment) and create a new one and then reinstall cadet env and cadet one more time.

Hope it helps,

Hey Franziska and welcome to the CADET-Forum! :partying_face:

Can I ask, how did you install CADET, via conda? Yesterday, another user also reported issues with umfpack. We “solved” the problem by nuking and reinstalling their conda environment.

First, remove the existing environment:

mamba activate base
mamba env remove -n cadet  # assuming your environment is called `cadet`

Note that I’m using mamba instead of conda. Ain’t nobody got time for resolving conda dependencies :sweat_smile: . And mamba is a much faster drop-in replacement for conda. For more information, see here.

To install mamba, run the following command in your base environment:

conda install mamba

For your new environment, I’d highly recommend creating an environment file. It makes setting up new environments much easier. For example, take the following and store it in an environment.yaml file:

name: cadet
  - conda-forge
  - python=3.10
  - cadet
  - pip
  - pip:
    - cadet-process

It defines a new environment called cadet and specifies all packages you want to install in that environment. As you can see, it’s also possible to specify pip packages. If you have other dependencies, just add them correspondingly. Moreover, you can specify the exact version of the package you want to use. This helps with reproducibility, should any of the packages have breaking changes in their API at some point.

You can store that file wherever you want. It might make sense to create one for each of your research projects but that’s up to you. Then, run the following command to create the environment (please modify the location to your environment file):

mamba env create -f <path/to/environment.yml>

By the way, for new users, we now recommend using CADET-Process. It’s a much improved user experience and provides many convenience methods for setting up models and analyzing results. It also includes a very flexible optimization suite, tailored for parameter estimation and process optimization.

Should you have any questions or if that does not solve your problem, please let us know. We can also setup a quick call.

Best regards,


Hi all,

I would like to share with you how I finally installed CADET on my company laptop.

  1. I created a new environment “cadet_env” and installed python 3.10 in there. This, I did in the anaconda navigator in the environment tab.
  2. In the home tab I selected the “cadet_env” and installed Spyder.
  3. I opened Anaconda prompt and activated the “cadet_env” there using: conda activate cadet-env
  4. If you have a vpn client on your computer that looks into everything you do, maybe this is the solution to your problem (it was the game changer for me): conda config --set ssl_verify false
  5. I installed CADET from conda-forge: Conda install -c conda-forge cadet=4.4.0 (this took a while and it somehow was important that Cadet was installed after Spyder. The other way round caused a lot of problems…)
  6. Next game changer for vpn challenges: pip install --trusted-host --trusted-host --trusted-host cadet-python

And finally the example from the CADET Introduction compiled successfully.

Hope this helps :).

All the best